UEFI doesn't detect live NixOS live USB?

I’m trying to create a NixOS live USB so I can install NixOS on a new computer. I’m on macOS so I typically create live USBs with Balena Etcher. I used it to create a Pop_OS! live USB with no issues. I tried with the NixOS ISO for the new computer (Gnome, x86_64), successfully burned the ISO to the USB using Etcher, but when I go to boot the USB the UEFI doesn’t even detect the USB as a boot device.

I poked around and found instructions to burn the ISO to the USB using dd:

$ sudo dd if=path/to/iso of=/dev/diskX

I did this and it’s still not detected by UEFI. I’ve also verified that Secure Boot is off.

What am I missing?

Can you give us the output of ‘parted -l’ ?

Where? parted is a Linux command and as I said I can’t boot the live USB. There’s probably an equivalent command on macOS using diskUtility. What information are you trying to find?

At the end of creating the live USB it’s always kicked out with an alert saying “this USB cannot be read by this computer”, but that happens with working live USBs created with Etcher as well.

I wanted to see, what boot flags is set.

I don’t see how to get that information short of starting up another working linux live USB to look at my broken NixOS USB.

I was able to read more information using Disk Utility on macOS and I saw a couple of things:

  • It was using MBR instead of a GUID Partition Map
  • macOS says the device isn’t bootable

I’ve switched to a GUID Partition Map so I’ll report back if that works.

1 Like

Here is a link that might be useful.

Formatting the live USB with GUID Partition Map turned out to be the solution.

1 Like