Unable to boot to plasma when using Nvidia

A few days ago I installed NixOS on my laptop. I set up everything except Nvidia drivers. When I decided to try them out I put the needed lines in my configuration.nix and reboot. When I rebooted I got dark screen whit that line in the top left. I can go to tty2 using ctrl+alt+F2, login and type startx but it seems like it doesn’t work. I the past I’ve had the same issue with other Linux distro so I decided to try to fix it as I did in that distro. I changed the display manager from SDDM to LightDM. It didn’t work here though.

My cofiguration can be found here
Later today I am going to upload a video of the reboot process.

Edit I am not that good in using Linux so I don’t know what logs or other stuff to provide.

Thanks in advance!

Not familiar with LightDM, but here are all of its options
Maybe try to remember what lightdm config did you put and put it in the nixos options

Use journalctl to check your Xorg logs for a line with (EE) in it

journalctl -xe --unit display-manager IIRC

Thanks to everyone who replied! I have decided to go to Arch for now because this distro is kind of hard for me to understend at my current level of knowage altough I have the same issue there… It seems like it is something wrong with my laptop.
Thanks again!

I am having this same issue now, does anyone know of a possible solution?

It’s a bit hard to help without knowing your configuration, and I’m not a Nix expert, but I ran into an issue booting Plasma with Nvidia after I had to change some environment variables in my configuration.nix because I also installed Hyprland. Changing them back seems to have helped.

Currently, KDE Plasma and Hyprland both boot with SDDM and the following for my Nvidia config:

services.xserver.videoDrivers = [ “nvidia” ];
hardware.nvidia = {
modesetting.enable = true;
open = true;
nvidiaSettings = true;
boot.blacklistedKernelModules = [ “nouveau” ];

I have barely changed the default config, I just added these lines for nvidia drivers

  ### Nvidia Drivers
  # Make sure opengl is enabled
  hardware.opengl = {
    enable = true;
    driSupport = true;
    driSupport32Bit = true;

  # Tell Xorg to use the nvidia driver (also valid for Wayland)
  services.xserver.videoDrivers = ["nvidia"];

  hardware.nvidia = {

    # Modesetting is needed for most Wayland compositors
    modesetting.enable = true;

    # Use the open source version of the kernel module
    # Only available on driver 515.43.04+
    open = false;

    # Enable the nvidia settings menu
    nvidiaSettings = true;

    # Optionally, you may need to select the appropriate driver version for your specific GPU.
    package = config.boot.kernelPackages.nvidiaPackages.production;

I have installed all apps through home-manager.
I alsio have just tried your config, it didnt help.