Unable to install Battle.net


I tried to follow Battle.net - NixOS Wiki, but the process keeps crashing, when the login screen appears. I also tried to use Lutris with various results. I got as far as being able to successfully install Battle.net, but when I installed WoW Classic, the game never started and always crashed.

Has anybody been able to install WoW recently on NixOS?


I just installed it with regular Steam (programs.steam.enable = true) and then added the client to my Steam library. Everything works fine, I am running with Proton-GE, I can play starcraft 2 and diablo iv.

Thanks, I tried to install Proton-GE using ProtonUp-Qt, then added Battlenet installer to the Steam, but I always get stuck on the login screen, not showing login button.

Screenshot from 2023-12-05 22.47.24

what desktop environment etc…?

i wasn’t able to get it to work on NixOS (kde, x11) after a few minutes so then gave up and just played it on my steam deck :man_shrugging:

I have tested this to work on both i3 (x11) and sway (wayland). No DE, just a tiling WM, but this shouldn’t matter at all.

I’m using Pantheon, but I also doubt that this would be the problem. But it’s really strange that it hangs on the login screen. When I was trying Lutris, I was able to get past the login screen (but then the game itself crashed). Now with Steam, I can’t even log in. Weird… Could it be drivers perhaps? I’m on ThinkPad T470.

Try this: https://www.reddit.com/r/linux_gaming/comments/187qvhw/anyone_else_having_issues_running_battlenet/kbh4m0o/

1 Like

Thanks so much. Running “export WINE_SIMULATE_WRITECOPY=1 && steam” solves the problem with the login screen of Battle.net. Now let’s see if I can actually run the WoW Classic.