Unable to Liveboot on Old PC

I’ve got an old PC that can boot some Linux live images but not others. I want to install NixOS on it. It’s a p6540f.

When I try to boot NixOS (both graphical and minimal), I can navigate the boot selection menu.

Per peterhoeg’s suggestion, I have tried all four options (default, nomodeset, copytoram, and debug) result in the following two messages:
Loading /boot/bzimage...ok
Loading /boot/initrd...ok
followed by blackness and then a reboot.

I’ll be back tomorrow with a list of Linux live images I can boot and live images I can’t boot to see if I can find something in common between the images that don’t support this machine.

In the mean time, is there any way I can log the boot process to determine where it failed?


Try to boot the nomodeset option from the grub menu.

1 Like

Thank you for your suggestion, peterhoeg!

Unfortunately, after trying again, it’s clear that none of the four boot options result in the desired behaviour. I’ve updated the OP to reflect this.

Try logging to a serial console - if the device is old it probably has a standard serial port. Just add console=ttyS0 to the kernel command line after hooking it up to another machine and see if it shows you what is going on.

That’s a good suggestion.

Unfortunately, the HP Pavilion p6540f isn’t quite old enough to have a serial port. I think this device is about ten to twelve years old.

I’ve been trying to boot from the instance of GRUB2 attached to my existing OS, because I can see the dmesg output when I do that. I’m having difficulty getting it to find the root filesystem, though. I tried adding root=LABEL=NIXOS_ISO to the kernel options as the provided bootloader does, but I’ve had no luck.