Unlocking gnome-keyring automatically upon login with KDE/SDDM?

Hi all,

I use KDE/geary, which requires running gnome-keyring in KDE. Every time I log in, I have to enter my password into a popup:

Unlock Keyring: 
Enter password to unlock: 
An application wants access to the keyring 'Default keyring', but it is locked.

I saw this previously being asked on stack exchange without a conclusive answer, and nothing I’ve tried thus far has seemed to work.

I deleted my keyring, remade a default keyring called login (set it as default with the same username and account). And am now getting a similar prompt during login:

Unlock Login Keyring: 
Enter password to unlock your login keyring: 
The login keyring did not get unlocked when you logged into your computer.

I was wondering if anyone had a solution for their configuration.nix, otherwise I’ll keep digging.

And found the solution:

services.gnome3.gnome-keyring.enable = true;
security.pam.services.sddm.enableGnomeKeyring = true;

Something must be wrong with the sddm pam modules, because we do

security.pam.services.login.enableGnomeKeyring = true;

in the gnome keyring module.

1 Like

Made an issue :slight_smile: https://github.com/NixOS/nixpkgs/issues/86884


What is the status on this?

My understanding is it is still not fixed, gnome-keyring module not unlocking login keyring on Plasma · Issue #86884 · NixOS/nixpkgs · GitHub

1 Like