Updated NixOS and now I can't boot into it

Hello, I have installed NixOS about a month ago for the first time fresh, I am running on the unstable channel and update my package list about once a week. Today after the update I noticed that I can’t anymore boot into the most recent version of NixOS. Can you please help me out? I already opened an issue too just to be sure but I want to know if I have to make some extra tests or write some more information. I have absolutely no clue on what to do in these cases as I just run “sudo nix-channel && sudo nixos-rebuild switch” and this time it didn’t work, that’s all.

You should be able to choose an older generation in the boot menu, which should boot. Then you can start debugging stuff. Looks likely that your graphics driver is crashing. What GPU are you using? Maybe you just need to use a different kernel version

1 Like

Oh yeah, I am 100% capable of rolling back. That’s hardly an issue.

The videocard is an AMD 7900XTX, but if what you wrote is correct the issue could be that the zen kernel I am using is for some reason bored. It always worked fine but I guess this release is just buggy.

I will test moving from zen kernel to normal one tomorrow after I wake up. If you have any other idea let me know please!

I have no idea if it’s the kernel or not. It’s just a guess. If it is the graphics driver, it could be the kernel, or it could be mesa (which has a much larger surface area than the kernel side of the graphics driver).

Yeah but I don’t really have a different mesa to try. Unless I load a pinned older version of it that is

I want to inform anyone who might have been in my same situation that it was a kernel issue, switching to regular Linux kernel had solved it and 6 hours ago a new update came out to the Zen kernel fixing it for that version too. This problem is now solved.

1 Like