Updating broke my system (Grub)

I have a ASUS TUF Gaming A15 FA507XI-LP028 laptop.
I use a tmpfs as root, my config.

I wanted to update my system, so I ran nix flake update (the system hasn’t been updated for roughly 12 days, I am on 24.05 stable with a few unstable packages).
I then ran nixos-rebuild switch --flake .#.
All seemed to be going well, I walked away from the computer. When I got back, the system was frozen ,capslock was flashing. The last few lines in the (frozen) terminal were about the kernel being updated and grub being rebuilt (I dual boot windows).
I restarted my computer (hard power off) and… grub was broken, I can’t boot into nixos (only the grub-rescue prompt appeared, but I can still boot into windows).
The impossible happened, nixos broke while updating. :slight_smile:

I guess my computer kernel panicked / locked up while grub was being rebuilt? I hope it’s not a hardware issue.

Files in /home on my data partition seem to be intact, so I guess only grub is broken.

I found a reddit post about a similar incident, but it isn’t of much help.

I have tried to boot from a live usb and use nixos-enter to regenerate GRUB, but I have had issues mounting the root partition… since its on tmpfs in ram.

I’ll probably just reinstall, but do you have some tips on how to nixos-enter (from a live-usb to rebuild grub) into a nix install without a root partition?