Upgraded from 23.11 to 24.05, now X fails to start

Hey, I just installed NixOS on a Thinkpad C13 Yoga Thinkpad. Not a Croustini side-by-side install, a full flash-non-Google-EFI-and-boot-from-install-USB install. I’m happy to report that the process worked and as far as I can tell all the device’s hardware is supported, though Wi-fi has been a bit flaky. I installed 23.11, messed around with configuration.nix and used the laptop as normal for some time creating a few 23.11 generations. Later I decided to set up home manager, and in doing so upgraded to 24.05. This process seemed to work fine, I can edit my home.nix to install/configure packages and all that jazz and changes apply as expected. Until I reboot. Attempting to boot from any 24.05 generation causes the system to hang while displaying the normal systemd boot logs, right before I should be seeing my greeter/login screen. None of the visible logs are suspect, but inspecting journalctl there are notable failures not present in the logs of successful boots on 23.11, which seem to point to an issue with amdgpu.

Any idea what might be the root issue here or how I might fix it? I’ve already tried playing with/forcing kernel versions, and managed to get 24.05 to use the exact same point release as the working 23.11 generation but the same failure occurred.

I’ve included first the logs of a boot where X fails, and then one from before when it worked.

journalctl log from a 24.05 boot where X fails: https://cdn.notepad.pw/7gbqiJkwiakRD8C0kj5B.txt

journalctl log from a 23.11 boot where things are all dandy: https://cdn.notepad.pw/nWAHSUnU4t66HDQgjLuD.txt