Upgrading to macOS Sonoma

Did anyone using nix and nix-darwin upgrade their macOS to Sonoma? I can’t find any information on whether it’s safe to upgrade.

I experienced issues upgrading. I haven’t determined what is going wrong, but after upgrading the /nix partition is not mounted and I haven’t been able to do so yet.

1 Like

I’d check up on the mounting service with:

launchctl print system/org.nixos.darwin-store

Maybe see if it’s mounted in /Volumes/ (this might indicate that macOS mounted it for some reason and pre-empted the mounting service).

Yeah, I have determined that that is the issue. The /nix partition is mounted. However I’m unable to get an more specific error. I’ve tried mounting it manually from diskutil as well as

launchctl load -w  system/org.nixos.darwin-store

followed by

log show --last 1m

Any ideas on how to determine why the partition is unable to be mount?

afaict the nix-daemon launchd service is running only darwin-store is the issue

The only thing i’ve noticed is that my /etc/synthetic.conf has the lines flipped compared to what is shown in this issue Rebooting always unmount Nix volume in macOS Monterey 12.5 · Issue #6839 · NixOS/nix · GitHub. ie.

$ cat /etc/synthetic.conf 
run	private/var/run

I’m not sure I follow. You say it is mounted, but that you can’t get it to mount. What does diskutil info 'Nix Store' say?

Order of synthetic.conf shouldn’t matter.

Sorry I meant to say the issue is that the partition is not mounted.

Turns out the issue was with a mdm profile update

1 Like

I upgraded yesterday. I had installed Nix using the Determinate installer as well as had nix-darwin setup. No issues at all after the upgrade (here’s my config if that matters).


I upgraded my personal laptop 2 days ago, no issues here either.


Thank you, @srid and @lilyball.

If you use zsh as your shell, can you report back on whether the upgrade overwrites /etc/zshrc?

/etc/zshrc was overwritten for me. Easy fix is just replace the nix shell files again in it.

You could likely get the same result with an uninstall and reinstall

This happens every minor or patch update as well. I recently moved the required config to my user .zshrc through home manager and now uogrades don’t affect it


@stobbsm @evanrichter Thanks for clarifying that yours still get overwritten. I’ve seen some reports that Apple had stopped overwriting it with the Sonoma update, but I was skeptical since there’s always a fair amount of noise around this problem.