Util-linux not giving access to commands

I’ve added utillinux to my package list in my config. it seems to have installed, but running many of the commands just returns command not found

I’ve tried many of the ls* commands, which haven’t worked. though I did try whereis and that ran.

generally this occurs when an executable isn’t able to find a shared library, do you mind listing some of the commands?

thanks much. all of the ls* commands don’t work. ie lsusb, lspci

I was able to run the lsusb and lspci commands from all of the following packages off of master: busybox, toybox, usbutils, pciutils.

Do you mind running nix-shell -p nix-info --run "nix-info -m" and pasting the output


yup, just got it running with pciutils as you were sending that. whoopsy. thanks for the help!

nix-shell -p nix-info --run "nix-info -m"
these paths will be fetched (0.05 MiB download, 0.28 MiB unpacked):
copying path '/nix/store/d43v6bx7r6fcaq3fbbfd5mwh1f5s7rmg-bash-interactive-4.4-p23-dev' from 'https://cache.nixos.org'...
 - system: `"x86_64-linux"`
 - host os: `Linux 5.7.6, NixOS, 20.03.2411.30fb4e1e206 (Markhor)`
 - multi-user?: `yes`
 - sandbox: `yes`
 - version: `nix-env (Nix) 2.3.6`
 - nixpkgs: `/nix/var/nix/profiles/per-user/root/channels/nixos`