Virt-manager # ubntu - screen sizes

I installed ubuntu via virt-manager

The offered screen sizes are not optimal for my 4k display (there will always be black spaces)

How to use 100% display solution (3840x2160) ?

"Default VGA memory size for QXL devices is 16M which is sufficient to drive resolutions approximately up to QHD (2560x1440). To enable higher resolutions, increase vga_memmb. "

Hello @kamentomov,
I’m new to qemu.

What would be the executable cmd command?

Is there a way to change it in virt-maanger?

In virt-manager go to the corresponding VM, open “Show virtual hardware details”, find Video (probably QXL) in the list and then go to the XML part where you can set the amout of video memory to something that is a power of two.

to change setting to “Virtio” is a quick solution (and there you can enable 3D acceleration, as well)

1 Like