Virtualbox installation not taking me to GRUB upon reboot

Problem: When I reboot, it takes me back to the installer menu, not GRUB. Installation itself reports no errors.

Version: 20.09
Minimal image

commands(straight from manual):

parted /dev/sda – mklabel msdos

parted /dev/sda – mkpart primary 1MiB -4GiB

parted /dev/sda – mkpart primary linux-swap -4GiB 100%


mkfs.ext4 -L nixos /dev/sda1

mkswap -L swap /dev/sda2

mount /dev/disk/by-label/nixos /mnt

swapon /dev/sda2

nixos-generate-config --root /mnt

#Need to change grub settings in config file

#Also would be nice if I could curl my own file

nixos-install --no-root-passwd


I would paste it all but clipboard from vbox isn’t working. I just uncommented the line: boot.loader.grub.device = "/dev/sda";

plus setting my time zone, defining packages to install, and enabling sound. Any advice to fix this is appreciated.

I solved it. It turned out I needed to remove the .ISO from virtualbox’s storage settings so it didn’t boot to the installation media.

1 Like