VirtualBox kernel driver is not accessible

Configuration

I tried to install Virtualbox 7.0.14 with Nix OS 24.05 as host system and used the following configuration:

virtualisation.virtualbox.host.enable = true;
virtualisation.virtualbox.host.enableExtensionPack = true;
users.users.user.extraGroups = [ “vboxusers” ];

Error

I got the following error message:
VirtualBox kernel driver is not accessible, permission problem. If you have built VirtualBox yourself, make sure that you do not have the vboxdrv kernel module from a different build or installation loaded. Also, make sure the vboxdrv udev rule gives you the permission you need to access the device. (VERR_VM_DRIVER_NOT_ACCESSIBLE).

Debug Steps

  1. I restarted the pc because of the kernel change. There was no change after the reboot.

  2. I tested if the models can be loaded:
    sudo modprobe vboxdrv
    sudo modprobe vboxnetflt
    sudo modprobe vboxnetadp
    There was no error.

  3. I checked the groups of users with the following command:
    groups user
    user : users wheel networkmanager vboxusers
    The user is in the vboxusers group

  4. I tried to call vboxconfig, but it is not available.

Request for assistance

At this point, I am seeking advice on how to address and resolve this issue. Any insights or solutions would be greatly appreciated.

1 Like