`vmmouse` failing when trying to boot the installer

I want to install NixOS on my freshly provided work laptop, but run into problems.

It seems as if the display-manager service is unable to start because of vmmouse is segfaulting.

I do not have that problem on any of my other machines. I tried the official plasma installer (nixos-plasma5-23.05.4527.60b9db998f71-x86_64-linux.iso) as well as a custom built installer, both showing the same error (± store paths) as shown in the photo.

The text below is through OCR, and except storepaths the same between the images (I have tried to roughly reconstruct the formatting after OCR broke it):

(II) config/udev: Adding input device ImPS/2 Generic Wheel Mouse (/dev/input/event6)
(**) ImPS/2 Generic Wheel Mouse: Applying InputClass "libinput pointer catchall"
(**) ImPS/2 Generic Wheel Mouse: Applying InputClass "VMMouse"
(II) LoadModule: "ummouse"
(II) Loading /nix/store/brfrmk3s19c3ih0y50mma i9ksrd4p7f1-xf86-input-ummouse-13.1.0/lib/xorg/modules/input/unmouse_drv.so
(II) Module unmouse: vendor="X.Org Foundation"
        compiled for, module version = 13.1.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 24.4
(II) UMWARE (0): UMMOUSE module was loaded
(II) Using input driver 'unmouse' for 'ImPS/2 Generic Wheel Mouse'
(**) ImPS/2 Generic Wheel Mouse: always reports core events
(EE) Backtrace:
(EE) 0: /nix/store/ha2fu9kc61q490q41b39zc5qhy9x8hz7-xorg-server-21.1.8/bin/X (OsSigHandler+0x29) [0x5b63a9]
(EE) 1: /nix/store/whypqfa83z4bsn43n4byumw80n4mg3r8-glibc-2.37-45/lib/libc.so.6 (_sigaction+0x50) [0x7fdcleafada0]
(EE) 2: /nix/store/brfrmk3s 19c3ih0y50mma i9ksrd4p7f1-xf86-input-ummouse-13.1.0/lib/xorg/modules/input/ummouse_drv.so (UMMous
(EE) 3: ? (?+0x0) [0x7ffd96701370]
(EE) Segmentation fault at address 0x0
Fatal server error:
(EE) Caught signal 11 (Segmentation fault), Server aborting

For reference here is also a link to the foto used to OCR from.

Google Photos

Can someone suggest a fix for this?

PS: I tried with and without nomodeset on both images to no avail.


It is a TUXEDO Gemini 17 Gen2, I will add a more thorough list of components and specs later today/tomorrow. (Not feeling well and need to get some rest first)

I just tried the Gnome ISO and it works using that.

This makes me think, this might be somehow an X Vs Wayland related issue.

Is there an easy way to disable the vmmouse and use another more/less generic driver for the system?

I want to avoid using Wayland on the system. Well to be exact, I do not want to run any WM other than awesome-wm on the system.

I have no problems though adjusting or building a custom ISO.

I did a quick grep for vmmouse in nixpkgs, and in the nixos folder it was mentioned only a single time, seemingly related to VMware guests, which are enabled by default in the installer.

I now built a custom installer that force-disables virtualisation.vmware.guest.enable. I was able to boot successfully after this change.

diff --git a/packages/installer/base.nix b/packages/installer/base.nix
index bfa3fa6..1fc7c44 100644
--- a/packages/installer/base.nix
+++ b/packages/installer/base.nix
@@ -1,4 +1,4 @@
-{modulesPath, ...}: {
+{modulesPath, lib, ...}: {
   _file = ./base.nix;
   imports = [
@@ -9,4 +9,8 @@
     edition = "nobbz";
     squashfsCompression = "zstd -Xcompression-level 10";
+  # VMware guest tools are enabled by default in the installer and caused issues
+  # on my Tuxedo laptop.
+  virtualisation.vmware.guest.enable = lib.mkForce false;