Warning: unknown setting 'extra-sandbox-paths'

I bought a new SSD. I tried to use my NixOS configuration in this new SSD. Since I converted my config to use flake, I tried this command inside the folder with flake.nix:

nixos-install --flake .#watchmen

It didn’t work, I don’t remember the error but it was something to do with restrict eval. I tried passing the github repo as flake and it worked partially:

nixos-install --flake https://github.com/tfmoraes/nixoscfg#watchmen

It gave a error after I set the root password. It install almost my system, like gnome and other stuffs, but nvidia not. So to install I copied configuration.nix to /etc/nixos and used nixos-install without nix-flakes. It worked.

After the installation and logged in the new system I updated the system and installed my user packages too using flakes correctly. But I every nix command that I use it show this warning: warning: unknown setting 'extra-sandbox-paths'. This setting is not set in any of my configurations. Is there a way to get away with this warning?

I can’t remember if this is new or not, but I feel like I just started seeing it myself (maybe only in certain edge cases?) and someone did just open an issue on it: https://github.com/NixOS/nixpkgs/issues/102632

1 Like

Thanks. I thought it was a inconsistency with my installation.

I ran into several issues while having package = pkgs.nixUnstable; in my nix configuration.
One of them was warning: unknown setting 'extra-sandbox-paths'. But also segmentation faults while rebuilding my nixos and build errors with some of the hardened.nix options too.

Therefore I decided to switch back to the 20.09. defaults: nix.package = pkgs.nix;. Then all of the problems disappeared.

I guess some of the unstable packages are literally unstable at present. :scream:

That has to do more with feature gating of the unstable nix package. Unless you really want to use flakes, or some of the new nix commands; there’s little difference between them for most users.

1 Like