Where to report solved issue?

I was experiencing an issue where my computer would immediately wake up after suspending, every time.

Kernel: Linux 6.1.45
Motherboard: B550M DS3H
CPU: AMD Ryzen 5 5600

Thanks to this arch wiki page, I was able to find this workaround:

services.udev.extraRules = ''
   ACTION=="add", SUBSYSTEM=="pci", DRIVER=="pcieport", ATTR{power/wakeup}="disabled"

I don’t know where I would report this issue so that it could be fixed upstream, or what upstream even is in this case, is it directly in the Linux kernel?

I see that Linux a denylist XHCI_SPURIOUS_WAKEUP, but that is only for USB, right?

1 Like

I think nixos-hardware is the place to be for this. Different hardware will have different things that should be prevented from causing wakeups. I imagine this particular one doesn’t normally cause that, except on specific hardware.

I think the denylist is part of udev though?

I guess I’ll submit it there. But it does feel unsatisfying, in an ideal world nixos-hardware would not need to exists, making it grow is like a signal that Linux hardware support is still not quite there yet.

I don’t think I have any uncommon hardware in particular, having an NVMe drive seems to be the cause of the issue.

Here’s are some examples of people with the same problem on different motherboards and different operating systems:

  1. updated BIOS: system immediately resumes from suspend (Gigabyte B550) / Kernel & Hardware / Arch Linux Forums
  2. https://www.reddit.com/r/gigabyte/comments/p5ewjn/b550i_pro_ax_f13_bios_sleep_issue_on_linux/
  3. In 20.1 AMD PC wakes immediately after sleep. Problem found. - Linux Mint Forums
  4. https://forums.linuxmint.com/viewtopic.php?p=2117343#p2117343
  5. https://artemis.sh/2023/04/09/b550i-pro-ax-linux-suspend-sleep.html

All these problems are marked as “solved”, but me and many other people still had it, a bug is not solved until it never happens to anyone else, if you ask me.

For completeness, the problem has been reported here: Gigabyte B5XX motherboards fail to suspend with NVMe drives · Issue #702 · NixOS/nixos-hardware · GitHub

1 Like

Yeah, but these are not bug reports, just calls for help on forums. Could be worth bringing up on the kernel ML.

fwiw, I just recalled that I ran into this too: