Wireplumber - GetManagedObjects() failed: org.freedesktop.DBus.Error.NameHasNoOwner

system: "x86_64-linux"
host os: Linux 6.1.31, NixOS, 23.05 (Stoat), 23.05.419.3a70dd92993
multi-user?: yes
sandbox: yes
version: nix-env (Nix) 2.13.3
channels(root): "nixgl, nixos-23.05, nixos-hardware"
channels(usera): ""
nixpkgs: /nix/var/nix/profiles/per-user/root/channels/nixos

wireplumber[2581]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NameHasNoOwner

How to fix this?

As long as you are providing so little context, it is very hard to diagnose.

When does that happen? Is it in response to any action?
Are there any other messages in the journal before that error?
Does this break any functionality you expect, or is the message sound purely informational?
What desktop environment do you use? Or if you are rolling your own, did you install XDG services like portals?

What have you tried in order to resolve this?
If there is no more relevant information in the journal, maybe look at the output of dbus-monitor --session (or Bustle, if you prefer graphical programs) around the time the failure happens to see what D-Bus name it is trying to get.

the upgrade from 2211 to 2305 was yesterday.

due to issues like window flickering, I installed

  • xdg-desktop-portal
    which appears to help a bit but does not solve it.

the config

  services.xserver.enable     = true ;
  services.xserver.displayManager.sddm.enable = true;
  services.xserver.desktopManager.plasma5.enable = true;
  services.xserver.desktopManager.plasma5.useQtScaling = true ;

there are messages before

Jun 02 13:00:07 P36 ksmserver[2692]: Qt: Session management error: networkIdsList argument is NULL
Jun 02 13:00:09 P36 kscreen_backend_launcher[3013]: kscreen.xcb.helper: Event Error: 147
Jun 02 13:00:09 P36 wireplumber[3031]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NameHasNoOwner

I tried to find help from google but without any success …

I will see if dbus-monitor --session can give further information

I do not see what could lead you to conclusion that xdg-desktop-portal has anything to do with window flickering. Either way, Plasma installs it out of the box so that can’t be it.

That is still very little. Errors often happen as a reaction to other errors and without more logs, we could be going on a wild goose chase of something that only occurs because pre-conditions are violated.

And you still have not provided the most important piece of info:

I’m receiving the same error. Using sway with a hacked up gnome-session. This occurs on login without any further interaction. Some failure on wireplumber start up maybe?

My hacked up sway session fails immediately afterwards. Tho I have no idea if this is the cause or not.