xkbOptions layout toggle not working

I would like to toggle between de and us keyboard layout. Following the article in the Arch Wiki, i defined the following in configuration.nix:

  services.xserver = {
    enable = true;
    layout = "de,us";
    xkbVariant = "nodeadkeys,";
    xkbOptions = "caps:backspace,grp:win_space_toggle";

but when i press win + space nothing happens. I also defined grp:ctrl_space_toggle but this isn’t working either.

What am i doing wrong?

What WM/DE do you use? Also note the warning at the top of the wiki page:

Note: XKB options can be overridden by the tools provided by some desktop environments such as GNOME and KDE.

I’m using awesomewm but have some config files left over from KDE. Could they still interfere?

EDIT: just deleted all hidden files with kde or plasma in them.