XP Pen Drivers on Linux

I am trying to run a driver for my XP-Pen graphics tablet with steam-run, but I need to run the driver with root permissions in order for it to work (here is the link to the linux drivers: https://www.xp-pen.com/download/artist-13-2nd-generation.html). I’ve also tried packaging the driver as a nix package, but I get the same problem.

Any help would be highly appreciated :slight_smile:

If you give what you tried so far it will be easier for us to help.

For now, you might want to get inspiration from:

  1. https://github.com/NixOS/nixpkgs/tree/master/pkgs/os-specific/linux/xp-pen-drivers
  2. Graphic Tablet VEIKK Linux Driver · Issue #90581 · NixOS/nixpkgs · GitHub

which basically unpack the .deb and fix a few hardcoded paths.

Also, what do you use steam-run for? If it’s just to run a non-patched binary, it might be simpler to enable nix-ld, this way your whole system is FHS-like, and you don’t need to worry about whether you can run root scripts or not. See my recommendation on nix-ld here.