Xserver fails to start with nvidia

I am using awesomewm and used to have

services.xserver.videoDrivers = [ "nvidia" ];
boot.kernelPackages = pkgs.linuxPackages_latest;

in my configuration.nix and it worked up until and including linux 5.19. When linux 5.19 reached EOL, the package for nvidia wasn’t compatible with linux 6.0 on Nixos 22.05 so i had to use the following:

  unstable = import <nixos-unstable> {
    ### override für Nvidia unstable
     config.allowUnfreePredicate = pkg:
       builtins.elem (lib.getName pkg) [ "nvidia-x11" "nvidia-settings" ];
in {

services.xserver.videoDrivers = [ "nvidia" ];
boot.kernelPackages = unstable.pkgs.linuxPackages_latest;

This worked and since i upgraded to Nixos 22.11 i can build Nixos with my original configuration again. However, after rebooting the xserver fails to start and i’m stuck in SDDM. I can enter the terminal there and see, that the xserver is the problem.

If i apply my overrides again and reboot, the xserver works but i would like to solve this problem to be able to drop the overrides. I was thinking that this problem would be solved shortly after the release of Nixos 22.11 but so far it hasn’t happened.

Can i solve this problem myself?

1 Like

If you’re reaching the greeter, that would mean X is functioning at the greeter, then failing when you start the session. Potentially related: Xorg segfaulting on login (after greeter) with nvidia drivers · Issue #206663 · NixOS/nixpkgs · GitHub


I see, thank you for your help!