XWayland+Nvidia jitter mitigation question

Hello all, this topic seem to be all over different forums and bugtrackers, but there hasn’t been any progress for (seemingly) years…

As I’m trying to use a laptop with dual GPU (intel+nvidia 980M), running opengl/vulkan things with xwayland produces artifacts of phantom frames popping in from the past. (as if frames go like 1 2 3 4 5 6 3 7 8 9 6 … ) resulting in horrible jitter. (was testing with unigine-heaven)

So far from all workarounds i’ve geathered only one worked - setting __GL_MaxFramesAllowed=1
But it drops performance up to 25%, and doesn’t seem to work for vulkan applications

So what I’m wondering is - are there better (maybe nixos-specific) workarounds?
(tried forceFullCompositionPipeline - no effect, tried __GL_YIELD=usleep, tried XWAYLAND_NO_GLAMOR - no effect)