Zprofile not read when login shell is zsh? [solved]

zsh seems to be exec’d without -l, so my zprofile isn’t being executed. I tested this by placing echo "Hello" > ~/proof in the file and logging in and out.

Why care?

  1. it’s just wrong :wink:
  2. I have various once-per-session config in my zprofile and I’d rather not rewrite my configs.

Manually running zsh -l works fine. Perhaps I’m configuring nixos wrong? Maybe there’s a bug?

Here’s my nixos config:

# Edit this configuration file to define what should be installed on
# your system.  Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running ‘nixos-help’).

{ config, pkgs, ... }:

  imports =
    [ # Include the results of the hardware scan.

  # Use the systemd-boot EFI boot loader.
  boot.loader.systemd-boot.enable = true;
  boot.loader.efi.canTouchEfiVariables = true;

  # networking.hostName = "nixos"; # Define your hostname.
  # networking.wireless.enable = true;  # Enables wireless support via wpa_supplicant.

  # The global useDHCP flag is deprecated, therefore explicitly set to false here.
  # Per-interface useDHCP will be mandatory in the future, so this generated config
  # replicates the default behaviour.
  networking.useDHCP = false;
  networking.interfaces.enp3s0.useDHCP = true;

  # Configure network proxy if necessary
  # networking.proxy.default = "http://user:password@proxy:port/";
  # networking.proxy.noProxy = ",localhost,internal.domain";

  # Select internationalisation properties.
  i18n.defaultLocale = "en_GB.UTF-8";
  console = {
    font = "Lat2-Terminus16";
    keyMap = "uk";

  # Set your time zone.
  # time.timeZone = "Europe/Amsterdam";

  # List packages installed in system profile. To search, run:
  # $ nix search wget
  environment.systemPackages = with pkgs; [
    curl neovim git mercurial atool rxvt-unicode feh firefox xsel pavucontrol

  fonts.fonts = with pkgs; [

  # Some programs need SUID wrappers, can be configured further or are
  # started in user sessions.
  programs.zsh = {
    enable = true;
    enableCompletion = true;
  # programs.mtr.enable = true;
  # programs.gnupg.agent = {
  #   enable = true;
  #   enableSSHSupport = true;
  #   pinentryFlavor = "gnome3";
  # };

  # List services that you want to enable:

  # Enable the OpenSSH daemon.
  services.openssh.enable = true;

  # Open ports in the firewall.
  # networking.firewall.allowedTCPPorts = [ ... ];
  # networking.firewall.allowedUDPPorts = [ ... ];
  # Or disable the firewall altogether.
  # networking.firewall.enable = false;

  # Enable CUPS to print documents.
  # services.printing.enable = true;

  # Enable sound.
  sound.enable = true;
  hardware.pulseaudio.enable = true;
  hardware.pulseaudio.support32Bit = true; # for compat with 32bit apps

  # Enable the X11 windowing system.
  services.xserver.enable = true;
  services.xserver.layout = "gb";
  # services.xserver.xkbOptions = "eurosign:e";

  services.xserver.windowManager.i3.enable = true;

  # Enable touchpad support.
  # services.xserver.libinput.enable = true;

  # Enable the KDE Desktop Environment.
  # services.xserver.displayManager.sddm.enable = true;
  # services.xserver.desktopManager.plasma5.enable = true;

  # Define a user account. Don't forget to set a password with ‘passwd’.
  users.users.colin = {
    isNormalUser = true;
    extraGroups = [ "audio" "wheel" ]; # Enable ‘sudo’ for the user.
    shell = pkgs.zsh;
    # I could define packages like this.
    # packages = []

  # This value determines the NixOS release from which the default
  # settings for stateful data, like file locations and database versions
  # on your system were taken. It‘s perfectly fine and recommended to leave
  # this value at the release version of the first install of this system.
  # Before changing this value read the documentation for this option
  # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
  system.stateVersion = "20.03"; # Did you read the comment?


Can you describe how to reproduce this? I am having trouble replicating it.

To test, I put some output it in ~/.zprofile. Here is what happens:

  • Open a new terminal - No output
  • Login to TTY - Output
  • Login via ssh - Output

That seems right to me so far so I must be missing something.

That’s also what I get. Perhaps my misconception is that I expect my login shell to be used for graphical logins, too? Is there some way to get that behaviour?

Edit: for now, I’ve set startx as my display manager and login via terminal instead of lightdm, and that works for me, but I’d like to understand why behaviour with lightdm is different.

I wouldn’t think so because zsh doesn’t get invoked on a graphical login. At least, I don’t think it does.

What are you trying to accomplish, is it zsh specific?

Yes, some of it is zsh-specific (e.g. setting up my fpath, but I could do most of that from .zshenv (which is sourced for every shell) if I needed to). I very rarely use display managers, so maybe this behaviour exists on other distros, too, but it seems pretty unsatisfactory: I don’t really want my fpath or path to be modified every time I start a shell, I’d prefer it to be inherited each time.

What shell is used as my login shell when I use a display manager?

My understanding is that when you login via a display manager to a graphical session you don’t have a login shell. You aren’t logging into a shell in this case.

Some distros still source a profile when starting such a session, but that is distro specific. I have never walked through what nixos does here but it should be possible to find by reading through the nix expressions. Either way, I am not sure any of those mechanisms would help with setting up a zsh specific environment.

1 Like

Thanks for your help, I really appreciate it! I guess that behaviour makes sense and works for most people, but I don’t really like it. I’ll just stick with terminal login :wink:

1 Like