Can't install citrix workspace

Good evening,

I’m new to the forum and Nixos in general. So far very impressed with the possibilities. I can figure out many things by reading documentation/googling but one thing I can’t seem to get working is my citrix workspace app that I need to login to my work.

So far I’ve followed this thread:

and this one

It seems I have to manually add the downloaded file to the nixos store so I’ve tried that:
nix-prefetch-url file://./linuxx64-
(I’m in the Downloads directory already but I get this output):
error: unable to download ‘file://./linuxx64-’: URL using bad/illegal format or missing URL (3)

I shouldn’t add a url right? Cause I’ve downloaded the file already.

In my configuration.nix I’ve added the following lines which I don’t know yet if they’re going to work:
pkg citrix-workspace
and I’ve added the following config:
nixpkgs.overlays = [
( self: super:
extraCerts = [ /etc/ssl/certs ];
in {
citrix_workspace = super.citrix_workspace.override {
inherit extraCerts;

This config I’ve got from this thread:

Sorry if I missed something to include or to explain a bit better. I’m an absolute beginner when it comes to Nixos. I hope someone can help me out here. Thanks in advance.


1 Like

I’ve solved the issue. Tested it in the live environment.

First allow unfree packages (I did it just temporary)

Then download the correct tar file from citrix:
It’s important to get the correct version:
linuxx64- so check for older files.

Then add the package to the nix store (this is where I got stuck, beginners mistake I’m affraid)

nix store add-file /home/nixos/Downloads/linuxx64- --extra-experimental-features nix-command

Then fetch the url:
nix-prefetch-url file://$PWD/linuxx64-

Then install the workspace app (I did it temporary in the nix environment)
nix-env -iA nixos.citrix_workspace

I’ve started up the workspace app and agreed. I’ve also installed Chromium (checked on serveral distros but Firefox doesn’t work so far).
I’ve downloaded the .ica file. I had to choose ‘open with’ Citrix workspace engine via Nautilus.

Then it started up flawlessly.
If someone has any questions please feel free to ask.

1 Like

thanks for sharing your solution. It is imperative based and goes against the declarative nixos pillar. is there a way to do this declaratively?

@tim1980 Thanks, just followed your method and it worked for me.