GDM does not list my user


I have a problem similar to the one here, however their solution doesn’t work for me.

My default shell is fish (why the hell is shell even important??), however I tried removing it and no effect.

The content of /var/lib/AccountsService/users/goose:


My user config:

  users.mutableUsers = false;
  users.users.goose = {
    isNormalUser = true;
    description = "goose";
    home = "/home/goose";
    extraGroups = [ "networkmanager" "wheel" "input" "libvirtd" "kvm" "lp" "scanner" ];
    hashedPassword = "$y$j9T$9Fuuefr5.C3uSqTNbwr9N0$SvINqsXiW7KfAhsklrzXIHe0h.b9nLIwBH9CfWDCpb1";
    shell =;              #
    useDefaultShell = false;  # these two lines I tried removing and got the same result: no users in gdm at all

I have = true in system settings too.

I didn’t find anything in journal when set gdm.debug = enabled.

Any idea?

Solved. Apparently fprintd was the problem. It was not enabled bc I already read some responses online about it, but it was still installed in system packages. So now it’s not anymore and gdm works

1 Like