GDM doesn't show user list despite settings

I use NixOS and I recently changed my user’s name, after some tinkering (Mostly adding the name attribute).
My OS is working fine now, however for some reason since the change, GDM stops showing a user list. Even after attempts to override this setting.

My GDM configuration looks like:

  services.xserver.displayManager.gdm = {
    enable = true;
    This was my attempt at fixing the issue. Needless to say, it didn't work.
    settings = {
      "org/gnome/login-screen" = {
        disable-user-list = false;

Furthermore, My user configuration is the following:

  users = {
    mutableUsers = false;
    users = {
      root.hashedPassword = /* Removed, for obvious reasons */;
      yoav = {
        name = /* Also removed, for similar reasons */;
        home = "/home/yoav";
        uid = 1000;
        isNormalUser = true;
        extraGroups = [ "wheel" "networkmanager" ];
        hashedPassword = /* Again, removed for the same reasons */;

Note: this is my first topic here, so if I am doing anything wrong, please tell me so.

Check /var/lib/AccountsService/users/<user> and see if the SystemAccount field is set to true. It should be false in order to show up in gdm’s list. For me just editing it and it worked fine. When I had this issue this reddit post helped me:

There should be a system account option somewhere in the users set I think. I’ll try that first, and then your suggestion of manually editing things.

EDIT: Whoops, forgot I had already set it.

This appears to be working. Do you have any additional information on why such a thing could be caused in the first place?