Graphical limbo: Element, Tutanota Desktop, and sometimes sites on Firefox and Brave all show windows that are missing stuff

Hi :slight_smile:

I came back to NixOS. I didn’t even last a day without it, because Debian gave me dependency hell even before I had finished installing everything that I need for work.

However I’ve got a problem:

Desired behavior and actual behavior

  • Opening Tutanota Desktop and being able to use it. I know the app has issues on NixOS (Tutanota support told me so), but before, I could at the very least open the app and see the GUI (although I couldn’t log in). Something changed recently. I’m not sure what. Given that situation, it’s okay if I use the alternative:
  • Opening on a web browser and being able to use it*. However, the calendar is missing entries. While this could be a Tutanota error, if I log in from another computer, the calendar does display. I wonder if my problem here is connected to the previous ‘desired behavior’ (Tutanota Desktop) and to the next ‘desired behavior’:
  • Opening and using Element. When I open Element, I get a white screen. Sometimes it flashes black. And if I wave the cursor around the window, it morphs into a hand, as if there was indeed buttons to press (except they are invisible).
  • Finally, there’s Brave Browser. I want to open it and use it. The problem is that I get white webpages. I do get to see the toolbar, but even going into settings gives me graphical artifacts, as if something wasn’t loading well.

All of these weren’t a problem before. I don’t know if it’s something I installed.

What I’ve tried

I rolled back to a version of Nix from 2023-7-28 by selecting what to boot into when I turn my computer on. With that, Element, Brave, and Tutanota Desktop (with its known issues) are back. Unfortunately, Tutanota web through Firefox is not. Surprisingly, Tutanota from Brave does make the entries on my calendar appear. To check if a Firefox extension or my cache was messing something up, I disabled all extensions and opened a private window. Logging into Tutanota that way still didn’t make the calendar entries appear.

I also tried uninstalling Element, Tutanota, and Brave. After that, I ran sudo nix-collect-garbage. The Brave, Element, and Tutanota entries were not part of the list of deleted files. I tried searching for how to uninstall them for sure without success.

Update: I changed my channel to unstable. Brave seems to work (including Tutanota calendar entries) as does the Tutanota Desktop app (with the Gnome desktop integration issues persisting, as usual— which I think is its own problem). Element is also working again. through Firefox does still give me a problem. I am not sure what’s happening…

What I am considering to try (in no particular order)

  • Change channel to unstable
  • Backing up my Home files and going for a clean reinstall of NixOS… ugh…
  • Anything you suggest so that I can fix this problem

*While typing this on Firefox, I realized that the post preview that I’d usually be able to see is not appearing. It seems as if is not the only website affected by whatever is happening. For what it’s worth, I’m typing away on the 2023-8-28 Nix version. Also, I refreshed the page (clearing cache) and my post preview reappeared. However, calendar entries have not, and so my original problem persists.

A summary of the packages I have installed and the services I have enabled can be found here.

Any help will be appreciated!

This sounds to me like you’ve hit multiple issues. The one that sounds familiar is Brave (or other chromium based applications, see: Chrome / Chromium Blank Pages

Thanks! I hadn’t considered looking for the issues individually. Deleting the GPU Cache folders for all of the relevant apps worked. I wonder if an upgrade caused the issue.

The exception to my success story was Firefox, because I couldn’t determine where the GPU Cache resides. I tried resetting all kinds of caches within the app, but the missing Tutanota calendar entries never appeared.

At the very least, I now have an alternative browser (Brave), in case Firefox doesn’t work :slight_smile:

I’ve had this issue with Chromium a couple of times, after upgrades. I primarily use Firefox, and haven’t been aware of it affecting Firefox.