Mysterious, unstoppable alert sounds

I’m getting alert sounds in urxvt that I can’t seem to turn off.

here’s what I’ve tried:

  • xset -b
  • xset b off
  • having set bell-style none in /etc/inputrc
  • turning on visual bell in urxvt (this actually works, but hurts my eyes)

what are my options here?

The wild thing is… I believe I turned off the pc speaker bell at some point… now the bell is an audio file! I never set that up (intentionally)! it’s a drip sound. I can’t find anything about alert sounds or bells in the nixos settings, and I have no idea what piece of software is enabling it.

Any ideas? <3 <3 <3

ps. another option would be to tone down the visual bell. can I choose the color of it?!

1 Like

Has anyone resolved this issue? I’ve tried adding gtk-error-bell=0 to all my gtk configs like this stack exchange post suggests here, but nevertheless it persists. I am going insane please help me my family is dying.

If you use Pipewire, perhaps try pipewire: 0.3.63 -> 0.3.63 by r-ryantm · Pull Request #207895 · NixOS/nixpkgs · GitHub

1 Like