Running nixos iso on asus rog stryx

On my asus rog stryx laptop I csnnot run the nixos iso I’ve built as it return to the bios screen after the grub screen.
What would be the problem?

how did you generate your iso?

The last asus motherboard board i dealt with, i had to mess around with secure boot, I either had to disable it, or mess around with encryption keys. It was quite fiddly in the end… not sure if that it directly related to your problem. It was quite a while ago…some my memory is a bit hazy.

That’s really fast that it reboots into firmware mode, that’s kind of odd. Can you give full specs? Is it using a 2xxx or 3xxx series card that is unsupported by nouveau, etc?

edit: re: secure boot, I also was suspicious, but I don’t think you would’ve even made it to grub if SB was the issue.

It’s the nvidia 3080, and effectively I didn’t build the iso with nvidia drivers.
I’ve already disabled secure boot and installed manjaro.

Now I will try to build the iso with nvidia proprietary drivers, I will tell you later how it goes.

No,still the same problem

I do know for sure that Nvidia + NixOS + 3080 can work (I’m running it) but I’m not sure the graphics driver is actually your issue (again, with how fast the boot menu is bailing to the firmware interface).

Unfortunately, I can’t think of a lot of things that might be happening, we don’t have a lot to go on due to the way it’s … well, not working.

“Progress„,as it shows the console loading until it locks up and freezes up
I did it by using the 20.09 nixos release with the latest linux kernel from master

could this be apci related? Have you tried turning of APCI off, or the myriad of kernel boot setting i have use to get linux to boot on buggy apci. This laptop is so new, does it even have apci interface, or has that ‘standard’ been replaced with some more buggy ;-).

worth a try.

it’s that or nixos could be missing a kernel/systemd patch that allows other distro’s to boot fine.

Again,I have manjaro running fine without having to disable ACPI or anything, I even have hibernation working.
I think I will ask around the manjaro forums

manjaro with either have a boot time setting, or a code level patch to something (systemd/kernel). It’s finding out what manjaro has that nixos doesn’t. Good luck…

Nixos tends to be pretty cutting edge in terms of kernels and system components…where the other distros tend to be … a ‘little’ behind…

take a scan through the majaro resources, see what kernel and patches they have in play. or anything the specifically mentions your laptop model.

So here are the patches manjaro applies

My intuition tells me it’s something in grub,as it fails right after selecting something from the menu,and also from systemd as the second tentative foze in systemd.

Also we should ask the diff between grub from release-20.09 and master.However all this is a bit above my head and I would need someone’s guide :sleepy: :sleepy:

Also I succeeded installing manjaro both with an earlier kernel and with the latest one

Wait, what changed though that let you get from grub to a kernel/systemd actually booting?

Linux’s nouveau doesn’t support the 2xxx or 3xxx series, so I’m not surprised it hung at what looks like the graphical target.

(The Manjaro iso presumably includes proprietary drivers.)


  1. Try the non-graphical installer. Do the installation and activate nvidia drivers in the config. When you boot into that config, things should then be okay.
  2. You could create (or ask someone to create) an installation ISO with nvidia drivers included. But you have to do the installation via CLI anyway, so this is sort of an unnecessary/“expensive” route, (but, some users are simply more comfortable being able to pull up firefox right there, while they’re installing).

Additional notes:

  1. With my 3080, GDM takes about 30 seconds to start in Wayland mode (and appears sort of hung like this in the meantime), and the it goes back to the console, and then another 30 seconds to load gnome-session in Wayland mode. I don’t know what these odd waits are about, but things seem fine after the delay.

EDIT: Sorry, just saw that you’d tried an ISO with nvidia. What config were you using for it?

EDIT2: I haven’t tried Plasma/SDDM with the 3080 yet (and when I do it will be with the Wayland PR applied).

the iso installer has videoDrivers=[“nvidia”]

Here is the repo used to generate the iso

Gotcha. Yeah, I’m not totally sure. Have you booted that config elsewhere before (aka, do you know that combination of desktop/displayManager options is good)? That would be my only other last idea, is that the auto-login process is wonky.

And/or try gdm+gnome, but I’m grasping here.

Alternatively, make a new ISO with a pre-defined user and SSH enabled. SSH in and try to see what’s jammed up?

(If I don’t reply after this, it’s just because I’m out of ideas! Good luck!)

again,running manjaro kde with sddm