Stuck creating a live USB iso containing broadcom_sta drivers


#1

Hey, I’m attempting to install NixOS on a macbook pro 2015. I dont’ have a USB ethernet adapter so I need to use the wireless card in it, which apparently requires a custom image, as per this issue.

So I’ve attempted to build a custom live CD as per the instructions in the manual. I installed NixOS in a virtualbox VM and then I created a file called iso.nix containing the following:

{config, packages, ...}:
{
  imports = [
    <nixpkgs/nixos/modules/installer/cd-dvd/installation-cd-graphical-kde.nix>
    <nixpkgs/nixos/modules/installer/cd-dvd/channel.nix> 
  ];
  boot.extraModulePackages = [ config.boot.kernelPackages.broadcom_sta ];
  boot.kernelModules = [ "wl" ];
  nixpkgs.config.allowUnfree = true;
}

Then I ran

nix-build '<nixpkgs/nixos>' -A config.system.build.isoImage -I nixos-config=iso.nix

Finally I copied the resulting image to a USB stick and booted it. However, once booted the running system still has no wireless drivers. Running nixos-option boot.extraModulePackages reports that the value of the attribute is an empty list.

Am I doing something wrong when creating the image?


#2

We should work on fixing that issue. But, I think you may also need to set:

hardware.enableAllFirmware = true;

For things to work


#3

Ah thanks, I’ll give that a try and report back.


#4

Unfortunately this didn’t work. Booting the resulting ISO still returns false for nixos-option hardware.enableAllFirmware.

Susupiciously the hash of the resulting ISO also didn’t change, which leads me to think I am generating the image incorrectly. Does the process I’ve followed look correct?

Thanks


#5

My bad, I was making a mistake copying the ISO to the USB stick. Formatting and copying the image resulting from the steps I described worked fine.