Virt-manager cannot find virtiofsd

I can start a VM from virt-manager, however, I cannot define shared directory. I see a popup window with error message.

Error starting domain: operation failed: Unable to find a satisfying virtiofsd

Traceback (most recent call last):
  File "/nix/store/k7gq8j86xhdqvqfdqqw7pyg9agpnaf7r-virt-manager-4.1.0/share/virt-manager/virtManager/asyncjob.py", line 72, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/nix/store/k7gq8j86xhdqvqfdqqw7pyg9agpnaf7r-virt-manager-4.1.0/share/virt-manager/virtManager/asyncjob.py", line 108, in tmpcb
    callback(*args, **kwargs)
  File "/nix/store/k7gq8j86xhdqvqfdqqw7pyg9agpnaf7r-virt-manager-4.1.0/share/virt-manager/virtManager/object/libvirtobject.py", line 57, in newfn
    ret = fn(self, *args, **kwargs)
  File "/nix/store/k7gq8j86xhdqvqfdqqw7pyg9agpnaf7r-virt-manager-4.1.0/share/virt-manager/virtManager/object/domain.py", line 1402, in startup
    self._backend.create()
  File "/nix/store/90qb43zkg0kyl7n3bs3l1q5v93s7883d-python3.10-libvirt-8.10.0/lib/python3.10/site-packages/libvirt.py", line 1373, in create
    raise libvirtError('virDomainCreate() failed')
libvirt.libvirtError: operation failed: Unable to find a satisfying virtiofsd

I did follow instructions on following sites.

I updated channel NixOS 22.11 and rebuilt the system; Same error.

What should I do to fix this error?

2 Likes

add virtiofsd into your systemPackages and add following into virt-manager filesystem xml:

  <binary path="/run/current-system/sw/bin/virtiofsd"/>
2 Likes

Is there a different approach now?

$ find /run/current-system/ -iname *virtiofsd*

$ /run/current-system/sw/bin/virtiofsd
bash: /run/current-system/sw/bin/virtiofsd: No such file or directory

I used

[user@nixos:~]$ which virtiofsd
/etc/profiles/per-user/user/bin/virtiofsd

Works for machine startup, thanks.

Im now getting this error

But my config is the same as the instructions…


Any ideas?

image
more info

Hi! Have you checked your source dir? In the screenshot, fourth line you have a typo. It reads Pyhton instead of Python.

That was not a typo. I got this working. Still not sure how though…

1 Like