Who uses NixOS with KDE?

I myself love KDE. Are there others who also use KDE Plasma?

There seem to be a couple of issues with KDE which Gnome users do not report. It would be great to have a bunch of people who can help each other for a well working KDE setup.

12 Likes

I do, and secretly believe that it’s insane that KDE isn’t “default” desktop on many distributions :slight_smile:

For me, KDE on NixOS just works – I don’t have any NixOS specific bugs to report.

8 Likes

That was kind of my fault after the 20.09 release. With the YY.03 and YY.09 release schedule, we essentially shipped an EOL version of plasma; and it usually had systemd and other issues as it lagged behind significantly from the rest of the ecosystem.

From a maintainership perspective at the time, the plasma effort was largely being handled by only @ttuegel, while gnome had worldofpeace, @jtojnar , and a few other gnome maintainers. I believe this has improved, but I don’t use a DE, so I don’t really look into it.

EDIT: I forgot to mention that with the YY.05 + YY.11 release schedule, this is much less of an issue now. Having more recent versions of gnome and plasma has mitigated most issues around compatibility with glibc, binutils and systemd.

5 Likes

I use it, and I love it.

I use KDE km NixOS, I like it and plan to continue using it.

What are these issues you speak of, BTW?

I’m also using it and it works pretty well.

What I’m not sure is how well the maintainer situation is with KDE and Plasma stuff.
It might be worth to add a maintainer team to nixpkgs/team-list.nix at 4ff6b2d67ffaad8a3be93b24a760aacbc79752fb · NixOS/nixpkgs · GitHub like there is for gnome, cinnamon and xfce.

I’m using KDE as well, and I like it. There are some minor issues, mainly with default applications, I think. Sometimes there is some weirdness but I guess I mostly got used to it. Can’t remember them off the top of my head.

I use KDE as well, and it generally works well out of the box. One thing I do miss is a way to configure plasma from my configuration.nix or with home-manager, and while there is some initial progress, it still isn’t easily possible.

I recently switched to KDE from none+xmonad. I’m pretty happy with it -
although the KDE part is mostly in the background & rarely interacted with:

I chose KDE because xmonad could be better integrated with it than GNOME.

As I do most of my configuration via my xmonad.hs file, the limitations of
configuring KDE in Nix have not presented as an issue.

1 Like

The main issue I am facing is that opening links from various applications do not work.

Here is one issue describing this phenomenon vscode-fhs: Cannot open links from vscode-fhs under KDE Plasma 5 · Issue #145354 · NixOS/nixpkgs · GitHub (and before this behaviour there was other buggy behaviour).

Here is another issue for probably the same problem: Apps launched by xdg-open can misbehave when called from FHS envs or wrapped programs · Issue #160923 · NixOS/nixpkgs · GitHub
while these may not be “KDE” problems, they seem to occur more often within KDE.

Because it was and is still difficult to find some maintainers for the first issue, I thought it would help to show that KDE is seriously used by many nixos users :wink: I am glad to see all your responses!

By the way, may power feature on KDE is the Kwin-Script Sticky Window Snapping

4 Likes

Adding this package to any FHS env or wrapped app that has trouble with xdg-open should workaround that issue for now.

4 Likes

I just realized that I also have another common problem:

attaching files to chromium based web apps often results in “zero size attachment” errors or similar

seems to effect Signal, Chrome, Chromium, … but sometimes it works, often not (probably after sleep everything gets corrupt). Firefox always works and seems to use another file-explorer. Might be that this is the reason.

EDIT: I couldn’t find it on the issues, hence opened a new issue for it: KDE chromium based systems cannot attach files after sleep - report empty files everywhere · Issue #164685 · NixOS/nixpkgs · GitHub

I had lot of random starting issues with Baloo (but not yet with 21.11)


Dolphin and not updated file listing (F5 as workaround)


before 4K displays were working fine (without any config hacks) but currently scaling makes all a bit inefficient and the GPU is running wild

lot of apps scale ok but e.g. not zoom …


not sure if it is a KDE based issue, with 21.11 tabs in Chrome based browsers cannot be changed in the sequence (and or extended to its own window and integrated back into the earlier browser window/tabs sequence)


not sure if it is a KDE based issue, printer is unstable and randomly gets lost …

Really liking KDE on NixOS, but occasionally I run into QT problems. It has been a few months (years?) without them, so maybe something has substantially improved. Not sure whether these issues are KDE-specific, though.

Plasma 5.24 landed in unstable today and I’m really liking it.

Only part I’m worried is that it took longer than a month for the PR to land in unstable after being merged in staging. Granted it was unrelated reasons, but it feels weird that Gnome issue can hold back plasma update.

A maintainer team shall be a great help. If nothing else, it will probably allow a central communication around the topic in a place less black-hole-y than nixpkgs PR/issue tracker.

3 Likes

I love KDE as well. Wayland + KDE + different DPI screens still have some glitches on 5.23.x but now with 5.24 being out I’m eager to try it and see if it gets better.

do you know a nice and clean config for Wayland + KDE (intel + nvidia & 4k displays)
[you would need a nixpkgs-wayland overlay?]

No overlay needed. Enable plasma as usual and select Wayland during login.

4K works well, including fractional scaling. Nvidia does not work with h/w acceleration, but software accel works well enough.

I just disabled nvidia and haven’t really missed it outside sporadic gaming and ML work.

However, if your nvidia is new enough you can use it in offload-mode and get the best of both worlds.

Edit: Regarding 4K, for some reason HDMI didn’t work with mt laptop for external 4K display. Same port, same machine, same cable worked on Windows. For NixOS I had to buy a DisplayPort cable and that worked. Surprisingly Windows didn’t work with that

I’ve been using KDE Plasma on NixOS unstable for 7 months now and I’m loving it so far.
The main issues that I’ve come across:

  • The built-in system store is super buggy and glitchy for me and basically has never worked correctly. By system store, I mean the window that opens up when you try to download community-made tools like themes, Kwin scripts, service menus and etc.
  • There are duplicate themes in system settings.
  • After the update to 5.23.3, the Ark service menus (compress, extract to) in dolphin just disappeared. They came back after updating to 5.23.5.
  • The zooming functionality of KWin has stopped working for me from 5.23.3 onwards.
  • The caching functionality of system settings broke for me a couple of times and I had to manually erase its cache from the home folder.
  • File associations sometimes just didn’t seem to work. For example, I would check the Remember application association for all files... checkbox when opening a file with a new file extension, but the next time I would try to open that file, it would open up the Select program... dialogue again. After a little digging, I found that installing some applications with nix profile sometimes messes up the location of its mime types for Plasma. After installing the same application through the system environment, the mime type and application association seemed to work.
  • The caching functionality of system settings broke for me a couple of times and I had to manually erase its cache from the home folder.

just want to thank you for your tip on clearing caches for system settings, it broke the editing of network connections for me on 5.24, had a horrible time troubleshooting, rolling back my configuration only led to more issues like sddm crashing on startup, presumably due to other cache problems as well

3 Likes